Di rečnik, v1.0.058

Antivari Software Design, s.a.
programi posebne namene

Poštanska adresa: Antivari Software Design, s.a., Čede Vasovića 12/23, 12000 Požarevac, Srbija
Stalna podrška: Mob: 063 / 8030363, Tel / Fax: 012 / 531358, Email: info@antivari.co.yu, Web: http://www.antivari.co.yu


Uvod u Di rečnik, v1.0

  • Namena
  • Pregled najvažnijih osobina
  • Šta je novo u izdanju Di rečnik, v1.0.058?
  • Tehnički detalji


Namena

Program je namenjen osobama kojima je potreban brz i nenametljiv srpsko-engleski i englesko-srpski rečnik. Potencijalni korisnici rečnika mogu biti svi koji često koriste računar za pretraživanje interneta, razmenu elektronskih pisama, proučavanje elektronske i druge dokumentacije, i sl.


Pregled najvažnijih osobina

Najvažnije osobine rečnika:

Brzo pokretanje/minimizovanje/zatvaranje iz Tray dela
Rečnik se može postaviti u Tray deo ekrana što u mnogome olakšava njegovo pozivanje i zatvaranje.

Pokretanje zajedno sa Windows-om
Rečnik se može automatski pokretati zajedno sa Windows-om, čime se osigurava da stalno bude dostupan.

Jednostavan i nenametljiv interfejs
Interfejs rečnika je krajnje jednostavan i nenametljiv, što osigurava da Vaš radni prostor uvek bude u prvom planu.

Prevođenje reči sa klipborda
Rečnik može automatski da „čita“ frazu sa klipborda čime se štedi na vremenu.

Aktiviranje rečnika na promenu sadržaja klipborda
Rečnik se može podesiti da se automatski pokrene (i prevede frazu) kada se dogodi neka promena na klipbordu.

Prevođenje reči Drag & Drop tehnikom
Rečnik može da „prihvati“ i prevede frazu koju ste „prevlačenjem“ preneli u polje za unos fraze.

Prevođenje selektovane reči priručnim menijem Internet Explorer-a
Rečnik postavlja stavku „Prevedi sa Di recnikom“ u kontekstni meni Internet Explorer-a – ako je neki tekst selektovan. Na taj način se brzo može doći do značenja neke fraze, bez potrebe za prethodnim kopiranjem na klipbord.

Pozivanje rečnika prečicom sa tastature
Rečnik se može pozvati iz bilo kog drugog programa preko globalno definisane prečice sa tastature koju je takođe moguće konfiguracijski podesiti.

Kontekstno osetljiv prozor za prevod
Rečnik može da bude kontekstno osetljiv. To je mehanizam gde pomeranjem miša preko već prevedenih reči možete dobiti ili njihova ostala značenja (dok držite levi taster miša) ili obeleženu stavku postaviti u prvi plan rečnika, kao da ste je ručno upisali (desni taster miša).

Sve važne komande mogu se zadati i preko tastature
Upotreba miša u radu sa rečnikom se može svesti na minimum a umesto njega se može koristiti tastatura – što je naročito važno za iskusnije korisnike.

Izgovor engleskih reči fraza
Rečnik poseduje i modul za izgovor engleskih reči i fraza, što može pomoći osobama koje se tek susreću sa engleskim jezikom.

Pamćenje poslednje traženih fraza
Rečnik može da pamti poslednje tražene fraze što olakšava snalaženje sa manje poznatim rečima.

Dvojezični interfejs
Rečnik može imati ili srpski ili engleski interfejs što je značajno za strance kojima je engleski jezik razumljiviji.

Baza reči sadrži sve latinične dijakritičke oznake
Baza reči sadrži sve latinične dijakritičke oznake: Š, Đ, Ž, Č i Ć, što u mnogim drugim rečnicima nije slučaj – gde se koriste: S, DJ, Z, C i C, kao zamene.

Konfiguracijska podešavanja
Podrazumevano ponašanje rečnika je moguće konfiguracijski promeniti. Moguće je na primer promeniti jezik interfejsa, metode traženja fraze, kao i mnogo toga drugog.

Veliki fond reči i fraza
Rečnik raspolaže fondom od preko 270,000 reči i fraza što je i više nego dovoljno za prosečnog korisnika.


Šta je novo u izdanju Di rečnik, v1.0.058?

    Ispravljena je greška zbog koje se rečnik sukobljavao sa nekim drugim programima (GoogeEarth, Corel, ICQ, neke igrice, ...) kada je bilo aktivno "Pozivanje rečnika tastaturom". Hvala Erkanu Islamoviću i Shadowed-u za testiranje.


Tehnički detalji

Program je razvijen na Borland C++ Builder-u 6 i koristi MS ACCESS bazu za relaciono smeštanje podataka (reči i fraza). Tehnologija korišćena za pristup bazi podataka je ADO (ActiveX Data Objects). Moduli za izgovor engleskih reči su Microsoft-ovi i instaliraju se automatski. Konfiguraciona podešavanja se čuvaju lokalno, u istom direktorijumu gde je i izvršni modul. U Registry bazu upisuje se putanja za automatsko startovanje programa kao i upis za pokretanje rečnika priručnim menijem Internet Explorer-a. Deinstalaciona procedura uklanja sve Registry upise koje je rečnik postavio. Instalaciona procedura je urađena besplatnim programom InnoSetup 5.1.11 i prevedena je od strane našeg Projektnog tima.


Instaliranje jezičke podrške za istočnoevropske zemlje i podešavanje latinične tastature

Problematika upotrebe YU latiničnih (i ćiriličnih) slovnih oznaka u Windows operativnim sistemima ima svoju dugu istoriju. Za manji deo su odgovorni tvorci samog operativnog sistema, a za veći deo smo krivi mi koji nismo na vreme prihvatali rešenja koja su nam se nudila.

S obzirom da su rešenja za upotrebu YU slovnih oznaka stizala „iz domaće kuhinje“ i bivala prihvaćena bez konsultacije sa našim autorizovanim institucijama, danas imamo šarenilo međusobno nekompatibilnih rešenja koja se teško iskorenjuju – što zbog navike, što zbog „mora“ već gotovih dokumenata koji su u opticaju.

Iako je još Windows 95 imao rešenje za upotrebu YU slovnih oznaka (preko odgovarajućeg kodnog rasporeda), u širokoj upotrebi u našoj zemlji su bili takozvani YUSCII fontovi koji su omogućavali laku upotrebu YU slovnih oznaka. Loš kvalitet YUSCII fontova kao i raznolikost fontova koji su nosili isto ime a bili različiti, stvarali su probleme u distribuciji dokumenata ili programskih tvorevina. Međutim, to skoro da nikome nije smetalo.

Od pojave Windowsa 95 pa do danas prošlo je preko deset godina, u kojima je stvoreno ko zna koliko dokumenata i softvera koji su bili van svih standarda što se tiče YU slovnih oznaka.

Tek sa ekspanzijom interneta i potrebom za usaglašavanjem standarda, konačno je i do naše svesti doprlo da poodavno postoje i drugi načini za prikaz YU slovnih oznaka.

Da ne bismo kudili samo sebe, rekli bi smo i da je Windows kumovao takvom stanju i to lošom (re)instalacionom procedurom kada je u pitanju ugradnja podrške za druge jezike osim engleskog, što mogu osetiti (poslednji preostali) korisnici Windows-a 98.

Pojavom Windows-a XP, odnosno usvajanjem UNICODE standarda za jezičku podršku, kao i jednostvnim dodavanjem/uklanjanjem podrške za specifične kodne rasporede, došlo se do (rekli bismo) zadovoljavajućeg rešenja kada su u pitanju YU latinične (i ćirilične) oznake.

Instaliranje jezičke podrške za istočnoevropske zemlje i kasnije podešavanje latinične tastature različito je na različitim verzijama Windows-a.

Naš rečnik ne koristi UNICODE standard, već korsti kodni raspored (kodnu stranu) 1250 za prikaz lokalnih latiničnih dijakritičkih oznaka. Osnovni razlog za takvu odluku je činjenica da razvojno okruženje kojim je rečnik razvijen – ne sadrži zvanično odobrenu podršku za UNICODE.

  • Podešavanje za Windows 98/SE/ME/NT/2000

  • Podešavanje za Windows XP


Podešavanje za Windows 98/SE/ME/NT/2000

Ako već imate instaliran Windows 98, SE, ME, NT ili 2000 (što je i logično) postoji šansa da ste u startu pogrešili. Naime u nekom trenutku instalacije, Windows Vas pita za podrazumevani tastaturni raspored (Keyboard Layout). Ako ste tu izabrali English, ili neki sličan (kao što bi to učinio i autor ovih redova) – pogrešili te. Trebalo je izabrati ili Serbian Latin ili Slovenian ili Croatian. Svaki naknadni pokušaj do-instaliranja podrške (Control Panel / Keyboard) ne vodi uspehu kada je u pitanju ispravno reprodukovnje svih latiničnih dijakritičkih oznaka u programskim formama. Što se tiče upotrebe u okviru MS Office paketa do-instaliranje daje rezultate, jer u stvari MS Office vrši nekakvu sopstvenu emulaciju. Takođe, u toku instalacije treba izabrati u okviru odeljka za Višejezičku podršku (Multilanguage Support): Easteurope i Cyrilic pakete.

Klasičnim re-instaliranjem Windows-a nećete moći naknadno podesiti sistem. Potrebno je sistem instalirati iznova – na praznom hard disku.

Kod Windows-a 2000, možete probati Control Panel / Regional Options / Set default...

Doduše, postoje i neki alternativni načini koji omogućavaju da sistem do-instalirate bez prethodnog brisanja sadržaja hard diska ali to su trikovi koji nisu provereni na više različitih sistema i stoga ih ovde ne bih promovisao.

Dakle, najbolji način da računar podesite za upotrebu latiničnih slovnih oznaka je instaliranje iznova – na praznom hard disku, uz odabir opcija koje smo gore pomenuli.


Podešavanje za Windows XP

Windows XP je operativni sistem koji se lako podešava za upotrebu latiničnih slovnih oznaka (putem kodnog rasporeda). Za početak pokrenite aplet Regional and Language Options iz Control Panel-a:

START / [ Settings ] / Control Panel / Regional and Language Options

i sledite putanju:

Kartica Languages / Taster Details / Kartica Settings / Taster Add /
Padajuća lista Input Language

Izaberite iz liste Vašu matičnu latiničnu tastaturu (ukoliko prethodno već nije bila u listi), dakle:

Serbian (Latin) ili
Croatian ili
Slovenian ili
Bosnian (Latin, Bosnia and Herzegovina) ili
Serbian (Latin, Bosnia and Herzegovina) ili
Croatian (Bosnia and Herzegovina)

i potvrdite tasterom OK Vaš izbor.

Dalje, u istom apletu sledite putanju:

Kartica Advanced / Padajuća lista iz okvira Language for non-Unicode programs

Izaberite opet Vašu matičnu latiničnu tastaturu (kao u listi iznad), čime ćete omogućiti da sva Vaša latinična slova budu ispravno reprodukovana na formama, u menijima i prilikom pretraživanja – što je i najbitnije. U principu, u obzir dolazi bilo koja latinična tastatura sa kodnom stranom 1250.


Pokretanje, pozivanje, zatvaranje i isključivanje rečnika

  • Pokretanje
  • Pozivanje
  • Zatvaranje
  • Isključivanje


Pokretanje

Nakon uspešnog instaliranja, rečnik je spreman za pokretanje na neki od načina koji su uobičajeni za Windows. Instalaciona procedura Vam je tokom procesa omogućila da postavite ikone u:

Start meni (podrazumevano se postavljaju)

Desktop (bilo je potrebno potvrditi)

Quick Launch (bilo je potrebno potvrditi)

Bilo kojim od gore navedenih načina možete pokrenuti rečnik. Kada se rečnik pokrene po prvi put, automatski će biti postavljen u Tray deo i biće stalno prisutan, čak i kada restart-ujete računar.

Takođe, i sama Instalaciona procedura po završetku (podrazumevano) nudi da se rečnik pokrene odmah, što je i poželjno.

Rečnik je pokrenut po prvi put i smešten u Tray deo

Nakon uspešnog pokretanja, rečnik se može pozvati na par načina.


Pozivanje

Pozivanje iz Tray-a

Pozivanje rečnika iz Tray-a je osnovni način da ga brzo pozovete i u praksi ćete ga verovatno najčešće i koristiti. Jednim levim klikom miša na ikonu u Tray-u pozivate rečnik:

Ikona rečnika u Tray-u

koji se može uočiti u levom gornjem uglu ekrana:

Glavna forma (prozor) rečnika

Poziciju rečnika možete sami odrediti jednostavnim premeštanjem rečnika mišem, ili prečicama sa tastature, što će biti detaljnije objašnjeno u nastavku dokumenta.

Pozivanje priručnim menijem Tray ikone

Tray ikona (kada je rečnik zatvoren) ima i svoj sopstveni priručni meni koji možete otvoriti klikom desnog tastera miša na ikonu. Rečnik pozivate izborom stavke iz menija – „Otvori rečnik“.

Priručni meni rečnika kada je zatvoren u Tray deo

Sa desne strane stavke „Otvori rečnik“ možete primetiti i prečicu sa tastature ALT+F12, koja u stvari predstavlja još jedan način pozivanja rečnika, koji nazivamo – pozivanje rečnika (globalnom) prečicom sa tastature.

Pozivanje (globalnom) prečicom sa tastature

Ponekada je jednostavnije rečnik pozvati globalno definisanom prečicom sa tastature, što je naročito interesantno iskusnijim korisnicima, koji rad mišem svode na neophodni minimum. U tu svrhu, automatski je podešeno da rečnik možete pozvati prečicom sa tastatute ALT+F12.

To u praksi znači da kada ste u nekom sasvim drugom programu, recimo MS Word-u, dovoljno je da pritisnete pomenutu kombinaciju tastera, i rečnik će biti automatski pozvan i postavljen iznad svih ostalih prozora. Ista prečica sa tastature i zatvara rečnik ako je već bio otvoren.

Kombinaciju tastera za globalno pozivanje (i zatvaranje) možete konfiguracijski i promeniti, što će biti detaljnije opisano u nastavku teksta.

Pozivanje priručnim menije IE Browsera

Rečnik je moguće pozvati i priručnim menijem bilo kog Internet Explorer baziranog browser-a, pri čemu će selektovana reč biti automatski upisana.

Priručni meni IE i stavka „Prevedi sa Di recnikom“

Prevođenje Drag & Drop tehnikom

Frazu je moguće prevesti takozvanom Drag & Drop tehnikom. To u praksi znači da će rečnik „prihvatiti“ i prevesti frazu koju ste selektovali i „vučenjem“ mišem preneli u polje za unos fraze.

Prevođenje Drag & Drop tehnikom

Pozivanje i prevođenje promenom sadržaj klipborda

Da bi se ovaj servis koristio prethodno je potrebno da stavka priručnog menija "Brzi klipbord isključen" bude dečekirana. Dok je servis aktivan, rečnik će prati trenutni sadržaj i promene klipborda i automatski se aktivirati i prevesti frazu kada se promena detektuje. Drugim rečima, rečnik će se automtski otvoriti i pokušati da prevede frazu čim neki tekst kopirate na klipbord, na neki od načina koji su uobičajeni za Windows. Na primer, sa CTRL+C, ili Edit/Copy, i slično.


Zatvaranje

Rečnik možete zatvoriti (vratiti u Tray) ne nekoliko načina:

1) Desnim klikom miša na ikonu u Tray-u, kada je rečnik već otvoren:

Ikona rečnika u Tray-u kada je rečnik već otvoren

2) Tasterom ESC, sa jednim ili sa dva pritiska, zavisno da li je već bila neka reč upisana;

3) Klikom Desnog tastera miša na znak ’X’ u prozoru za prevod.

4) Kombinacijom tastera ALT+F4, što je i standardni način propisan od strane Windows-a;

5) Priručnim menijem – izborom stavke „Zatvori program u ’tray’“ koji se poziva desnim tasterom miša na slobodnu površinu rečnika ili prečicom sa tastature ALT+U:

Priručni meni rečnika, i stavka „Zatvori program u ‘tray’“


Isključivanje

Rečnik možete privremeno isključiti (bez deinstaliranja), na dva načina:

1) Kada je rečnik već zatvoren u Tray-u, desnim tasterom miša na ikonu dobijate priručni meni gde treba izabrati stavku „Izlaz“:

Stavka „Izlaz“ priručnog menija u Tray-u

Rečnik će se na ovaj način isključiti samo privremeno, do prvog sledećeg restart-ovanja Vašeg računara. Ako želite da i nakon restart-ovanja rečnik ostane isključen, prethodno skinite potvrdu i sa stavke „Pokreni sa Windows-om“ istog priručnog menija:

Stavka „Pokreni sa Windows-om“ priručnog menija u Tray-u

2) Kada je rečnik već otvoren, u priručnom meniju prethodno skinite potvrdu sa stavke (ako već nije skinuta) „Podešavanja / Zatvori program u ‘tray’“:

Stavka „Podešavanja / Zatvori program u ’tray’“

a zatim izaberite stavku priručnog menija „Izlaz“. Rečnik će na taj način ostati isključen do prvog sledećeg restart-ovanja Vašeg računara, nakon čega će se vratiti minimizovan kao običan program, t.j. neće se vratiti u Tray jer smo bili skinuli potvrdu sa te stavke.

Ako želite da rečnik nakon restart-ovanja ostane isključen, prethodno treba „skinuti“ potvrdu i sa stavke „Podešavanja / Pokreni sa Windows-om“:

Stavka „Podešavanja / Pokreni sa Windows-om“

Rečnik se ponovo pokreće na načine koje smo već opisali na početku ovog odeljka, a vraća u prvobitno konfiguracijsko stanje (pokretanje sa Windows-ima i zatvaranje u Tray) obrnutom procedurom – ponovnim potvrđivanjem stavki koje su bile „skinute“.


Rad sa programom

  • Glavna forma (prozor) rečnika
  • Prozor za prevod
  • Priručni meni
  • Prečice sa tastature


Glavna forma (prozor) rečnika

Osnovna ideja ovog rečnika je da bude jednostavan i nenametljiv – a ipak dovoljno funkcionalan. Želeli smo po svaku cenu da izbegnemo robusne interfejse, koji rečnik postavljaju u prvi plan, zanemarujući stavrni cilj korisnika – a to je najčešće da sazna ili pronađe značenje neke reči ili fraze, i da se potom što pre vrati svom radu. Stoga je interfejs ovog rečnika krajnje jednostavan, i već ste ga delimično upoznali u gornjem delu dokumenta.

Glavna forma (prozor) rečnika podeljena je u dva dela:

  • slobodni deo i

  • polje za unos fraze.

Glavna forma (prozor) rečnika


Slobodni deo

Slobodni deo rečnika ima višestruku namenu:

Pomeranje rečnika

Hvatanjem rečnika mišem za slobodnu površinu, rečnik možete pomeriti u deo ekrana koji Vam najviše odgovara. Autor ovih redova najviše voli da mu rečnik bude u gornjem desnom uglu, neznatno ispod ikona za zatvaranje, minimizovanje i maksimizovanje nekog programa.

Rečnik je pozicioniran u gornji desni ugao

Promena jezika za pretragu

Rečnik je konfiguracijski podešen da frazu koju unosite automatski traži i među engleskim i među srpskim rečima.Po našem skromnom mišljenu, ovo je i najoptimalniji način pretrage, jer će fraza koju tražite (bila ona engleska ili srpska) na kraju sama „isplivati“ na površinu. Reči koje se isto pišu i imaju ista značenja u oba jezika su retke, pa je stoga suvišno opterećivati se pitanjem izbora jezika za pretragu.

Međutim, ako ipak želite da frazu tražite samo u englskom ili samo u srpskom delu rečnika, duplim klikom levog tastera miša na slobdnu površinu rečnika ciklično birate između pretraživanja: oba rečnika, samo engleskog rečnika ili samo srpskog rečnika.

Ciklično biranje „jezika za pretragu“

Pozivanje priručnog menija

Priručni meni rečnika ste već imali prilike da upoznate. Otvara se desnim klikom miša na njegov slobodni deo. Priručni meni ima i svoje podmenije, o čemu ćemo više govoriti u nastavku dokumenta.

Priručni meni rečnika


Polje za unos fraze

Polje za unos fraze je obično edit polje u koje ćete upisivati frazu čija značenja želite da pronađete. U donjem primeru upisali smo reč „fraza“ i dobili tri njena značenja u takozvanom prozoru za prevod.

Polje za unos fraze (i prevod)


Prozor za prevod

Prozor za prevod je posebna forma u obliku usmerenog balona (balloon), u kojoj ćete pratiti rezultate Vaše pretrage. Na sledećoj slici možete pogledati primer prozora za prevod:

Prozor za prevod sa ukucanom frazom: „film“


Veličina prozora za prevod

Veličina prozora za prevod se automatski usklađuje u odnosu na količinu teksta koji je potrebno prikazati. Rečnik podrazumevano prikazuje najviše 15 prevoda koji odgovaraju zadatom kriterijumu. Konfiguracijski je podešeno i da se dugački prevodi prelome, da bi radni prostor korisnika što je moguće više bio u prvom planu.


Položaj prozora za prevod

Položaj prozora za prevod se automatski usklađuje u odnosu na položaj rečnika i količinu teksta koji je potrebno prikazati. Na sledećim slikama je prikazano kako se prozor za prevod prilagođava situaciji:

Prozor za prevod se prilagođava situaciji

Prozor za prevod će uvek pokušati (po mogućnosti) i da se „sabije“ suprotno od centra ekrana, da bi što više štedeo radnu površinu korisnika:

Prozor za prevod se (po mogućnosti) „sabija“ suprotno od centra ekrana


Elementi prozora za prevod

Svaki prozor za prevod ima dve osnovne sekcije:

  • Naslovnu liniju i

  • Polje prevoda.

„Naslovna linija“ i „Polje prevoda“ prozora za prevod

Naslovna linija i Polje prevoda mogu ponekad sadržati i neki informativni tekst (nevezano za prevod), i takav tekst ćemo nazvati – sistemski tekst.


Naslovna linija

Na naslovnoj liniji nalaze se:

  • ikona stanja pretraživanja,

  • naslov pretraživanja,

  • ikona stanja editora i

  • ikona za zatvaranje prozora za prevod.

„Naslovna linija“ prozora za prevod

Ikona stanja pretraživanja

Menja se u zavisnosti od trenutnog stanja pretrage ili može biti specifična za sistemski tekst.

Ikone koje su vezane za trenutno stanja pretraživanja:

postoji tačno jedna fraza koja zadovoljava zadati kriterijum,

postoji više od jedne fraze koja zadovljava zadati kriterijum,

ni jedna fraza ne zadovoljava zadati kriterijum.

Ikone koje su specifične za sistemski tekst

osnovni podaci o programu,

spisak prečica sa tastature,

dnevni savetnik,

dobrovoljne donacije,

greška pri otvaranju Help datoteke,

interna greška.

Ikona stanja pretraživanja

Menja se u zavisnosti od trenutnog stanja pretrage ili može biti specifična za sistemski tekst. Što se tiče naslova koji je specifičan za trenutno stanje pretrage, možete dobiti sledeće poruke:

Naslov pretraživanja koji je vezan za trenutno stanje pretrage:

Prvih 15: Y (gde je Y ključna reč pretrage),

Poslednjih X: Y (gde je Y ključna reč pretrage, a X broj preostalih fraza) i

Bingo! (reč je pronađena, i to samo jedna),

Nema pojavljivanja: Y (gde je Y ključna reč pretrage).

Ključna reč pretrage (koju smo u gornjim primerima obeležili slovom Y), može sadržati i posebne modifikatore na početku ili kraju fraze, i to u vidu zvezdice (*):

Modifikatori ključne reči pretrage:

Y (bez modifikatora), traže se fraze koje su identične kao i Y,

Y* (modifikator je iza), traže se fraze koje počinju sa Y,

*Y (modifikator je ispred), traže se fraze koje završavaju na Y,

*Y* (modifikator je sa obe strane), traže se fraze koje sadrže Y.

O načinima pretrage i njihovom podešavanju biće više reči u nastavku dokumenta.

Ikona stanja editora

Simbolično pokazuje da li je tekst u polju prevoda samo za pregled ili se može čak i „selektovati“ radi kopiranja (CTRL+C).

Ikone stanja editora:

Zaključano (polje prevoda se može samo pregledati),

Otključano (polje prevoda se može i „selektovati“ radi kopiranja).

Klikom na ikonu stanja editora menjate njegovo stanje. Konfiguracijski je moguće podesti stanje koje je poželjno da bude podrazumevano.

Ikona za zatvaranje prozora za prevod

Ikona za zatvaranje ( [image] ) je opšte prepoznatljiva i služi da zatvori prozor za prevod. Ovaj prozor je moguće zatvoriti i tasterom ESC.


Polje prevoda

Polje prevoda je najvažniji deo rečnika i u njemu pratite trenutno stanje pretrage, tj. u njemu će biti ispisane reči i fraze koje zadovoljavaju kriterijum koji upisujete u edit polje. Polje prevoda može sadržati i neki sistemski tekst, o čemu će više reči biti u nastavku dokumenta. U polju prevoda možete uočiti: podebljan tekst plave boje, podebljan tekst crvene boje i običan tekst crne boje.

Tekst plave boje predstavlja srpsku reč ili frazu, dok su u nastavku data sva engleska značenja te reči ili fraze, odvojene tačka-zarezom.

Tekst crvene boje predstavlja englesku reč ili frazu, dok su u nastavku data sva srpska značenja te reči ili fraze, odvojene tačka-zarezom.

Već smo ranije bili pomenuli da je rečnik je konfiguracijski podešen da frazu koju unosite automatski traži i među engleskim i među srpskim rečima. Tako je u ovom slučaju rečnik pronašao sve fraze koje počinju sa „SITUA“.

Međutim, ako želite da reči i fraze tražite samo u englskom ili samo u srpskom delu rečnika, duplim klikom levog tastera miša na slobdnu površinu rečnika ciklično birate između pretraživanja: oba rečnika, samo engleskog rečnika ili samo srpskog rečnika. Poslednje korišćen način pretrage, rečnik će smatrati podrazumevanim prilikom sledećeg pozivanja ili pokretanja.

„Polje prevoda“ prozora za prevod

Otključavanje editora polja prevoda

Otključavanje editora polja prevoda je mogućnost da „selektujete“ neki deo teksta u polju prevoda radi eventualnog kopiranja (CTRL+C). Editor se otključava ( [image] ) ili ponovo zaključava ( [image] ) levim klikom miša na ikonu katanca (ikona stanja editora). Isti efekat se može postići i prečicom sa tastature ALT+S.

„Polje prevoda“ je otključano

Kontekstno osetljivo polje prevoda

Polje prevoda je kontekstno osetljivo. Prelaskom miša preko prevoda, u prvi plan (u vidu Hint-a) biće naznačena reč koja se nalazi ispod kursora miša:

Naznačena reč: „smešten“

U trenutku kada je neka reč naznačena, ako pritisnete i zadržite levi taster miša – dobićete sva druga značenja naznačene reči:

Sva druga značenja reči: „smešten“

U trenutku kada je neka reč naznačena, ako pritisnete desni taster miša – rečnik će u prvi plan staviti naznačenu reč – kao da ste je ručno upisali:

Naznačena reč: „smešten“ – postavljena je u prvi plan


Priručni meni

Priručni meni rečnika otvarate klikom desnog tastera miša na slobodnu površinu rečnika ili prečicom sa tastature ALT+U.

Priručni meni rečnika


Kopiranje fraze i značenja na klipbord

Izborom stavki priručnog menija (na slici), na klipbord možete kopirati: frazu, značenja ili i frazu i značenja. Ako u listi ima više od jedne stavke, kopira se prva sa liste. Kada kopirate i frazu i značenja, fraza će biti odvojena od značenja TAB kontrolnim kodom. Isti efekat se može postići i prečicama sa tastature ALT+1, ALT+2 i ALT+3.

Kopiranje fraze i značenja na klipbord


Prelazak u prozor za prevod

Izborom stavke „Pređi u prozor za prevod“ – „otključavate“ polje prevoda i dobijate mogućnost da ručno „selektujete“ neki deo teksta radi eventualnog kopiranja (CTRL+C). Editor se takođe otključava ( [image] ) ili ponovo zaključava ( [image] ) levim klikom miša na ikonu katanca (ikona stanja editora). Isti efekat se može postići i prečicom sa tastature ALT+S.

Prelazak u prozor za prevod


Izgovor engleskih reči

Rečnik ima mogućnost izgovora engleskih reči. „Selektovanu“ englesku reč (prvu u listi) izgovarate izborom stavke „Izgovori“ ili prečicom sa tastature ALT+Z. Takođe, nakon pritiska tastera ENTER, rečnik izgovara (englesku) reč is stavlja je u listu poslednje korišćenih fraza.

Izgovor engleskih reči


Izbor jezika interfejsa i usklađivanje tastature

Rečnik (po želji) može imati ili engleski ili srpski interfejs. Jezik interfejsa možete menjati i dinamički prečicom sa tastature ALT+I. Usklađivanje tastature je proces dinamičkog menjanja tastaturnog rasporeda (Keyboard Layout) u odnosu na trenutno izabrani jezik za pretraživnje. Ako je izabran engleski jezik – i tastatura će biti po engleskom rasporedu. Ako je izabran srpski jezik ili oba – tastatura će biti po srpkom rasporedu. Tastaturni raspored možete menjati i sami na način uobičajen za Windows.

Izbor jezika „Interfejsa“

Na slikama možete uočiti trenutno izabrani tasturni raspored EN (engleski) i SR (srpski):

Stavka „Uskladi tastaturu“


Izbor jezika za pretragu

Rečnik je konfiguracijski podešen da frazu koju unosite automatski traži i među engleskim i među srpskim rečima. Po našem skromnom mišljenu, ovo je i najoptimalniji način pretrage, jer će fraza koju tražite (bila ona engleska ili srpska) na kraju sama „isplivati“ na površinu. Reči koje se isto pišu i imaju ista značenja u oba jezika su retke, pa je stoga suvišno opterećivati se pitanjem izbora jezika za pretragu.

Mi Vam navodimo jedan primer, gde se reč isto piše i znači u oba jezika:

Reč „zebra“ kada tražimo u „oba“ jezika

Reč „zebra“ se isto piše i ima isto značenje u oba jezika

Međutim, ako ipak želite da frazu tražite samo u englskom ili samo u srpskom delu rečnika, duplim klikom levog tastera miša na slobdnu površinu rečnika ciklično birate između pretraživanja: oba rečnika, samo engleskog rečnika ili samo srpskog rečnika.

Isti efekat postižete i prečicom sa tastature ALT+L, ili izborom željene stavke u priručnom meniju (kao na slici).

Izbor „Jezika za pretragu“


Izbor načina za pretragu

Rečnik je konfiguracijski podešen da u prozor za prevod upisuje prvih 15 prevoda koji „počinju sa“ frazom koju unosite. Ovaj način pretrage ćete najčešće i koristiti.

Međutim, postoje slučajevi kada ćete poželeti i neki drugačiji način za preragu. Na primer, možete tražiti prevode koji u sebi „sadrže“ frazu koju unosite, možete tražiti prevode koji „završavaju na“ ili su „jednaki sa“ frazom koju unosite.

Trenutno izabrani način za pretragu možete uvek prepoznati u naslovu pretraživanja, na osnovu ključne reči pretrage i posebnih modifikatora na početku ili kraju fraze, i to u vidu zvezdice (*):

Modifikatori ključne reči pretrage:

Ključna reč (bez modifikatora), traži se fraza koja je identična sa „Ključna reč“,

Ključna reč * (modifikator je iza), traži se fraza koja počinje sa „Ključna reč“,

* Ključna reč (modifikator je ispred), traži se fraza koja završava na „Ključna reč“,

* Ključna reč * (modifikator je sa obe strane), traži se fraza koja sadrži „Ključna reč“.

Način pretrge je moguće menjati i prečicama sa tastature:

ALT+B Traži prevode koji „počinju sa“ traženom frazom,

ALT+C Traži prevode koji „sadrže“ traženu frazu,

ALT+E Traži prevode koji „završavaju na“ traženu frazu i

ALT+W Traži prevode koji su „jednaki sa“ traženom frazom.

Izbor „Metoda traženja fraze“


Poslednje fraze

Rečnik ima mogućnost „pamćenja“ poslednje pronađenih fraza, i to po 10 za svaki izabrani jezik pretrage (Oba, Eng ili Srp). Pronađnu frazu „snimate“ tako što nakon uspešnog pronalaska pritisnete taster ENTER. Ako se radi o engleskoj reči ona će istovremeno biti i izgovorena.

Fraza će biti snimljena u listu poslednjih fraza i kada je pozvana priručnim menijem In t ernet Explorer-a ili preko "brzog klipborda".

Sve poslednje pronađene fraze možete u celosti obrisati stavkom priručnog menija „Obriši poslednje fraze“, ili prečicom sa tastature ALT+H.

Stavka „Poslednje fraze“ priručnog menija

Zapamćene fraze vraćate u polje editora tako što iz odgovarajućeg podmenija izaberete željenu frazu. Na primer, na slici (dole) su prikazane reči koje su snimljene u podmeniju „Oba“. Kao što se vidi, snimili smo četiri fraze, dok je ostao prostor za još šest. Kada je lista popunjena a upravo snimamo sledeću frazu, najstarija fraza se briše a nova upisuje, i tako redom.

Podmeni „Oba“ stavke priručnog menija „Poslednje fraze“


Podešavanja

Stavka „Podešavanja“ priručnog menija je centralno mesto gde je moguće podesiti podrazumevano ponašanje rečnika, i to jednostavnim „čekiranjem“ željenih stavki.

Ostala podrazumevana podešavanja rečnika (interfejs, izabrani jezik i metode traženja fraze) biće prihvaćena na osnovu poslednjeg korišćenog stanja.

O podešavanjima će biti više reči u nastavku dokumenta.

Stavka „Podešavanja“ priručnog menija


Podešavanja

Već smo ranije rekli da je stavka priručnog menija „Podešavanja“ centralno mesto gde je moguće podesiti podrazumevano ponašanje rečnika, i to jednostavnim „čekiranjem“ željenih stavki.

Ostala podrazumevana podešavanja rečnika (interfejs, izabrani jezik i metode traženja fraze) biće prihvaćena na osnovu poslednjeg korišćenog stanja.

Priručni meni „Podešavanja“

Pokreni sa Windows-om

Kada je „čekirana“, ova stavka obezbeđuje da se rečnik nakon podizanja Windows-a uvek automatski startuje, i to minimizovan kao obična aplikacija (ako nije podešeno i da bude u Tray delu), ili će biti smešten u Tray (ako je tako podešeno).

Zatvori program u ’tray’

Kada je „čekirana“, ova stavka obezbeđuje da se rečnik nakon pokretanja „smesti“ u Tray deo.

Pametni klipbord

Kada je „čekirana“, ova stavka obezbeđuje da rečnik nakon pozivanja automatski pokuša da prevede frazu koja se (eventualno) nalazi na klipbordu.

Brzi klipbord isključen

Kada je „dečekirana“, ova stavka obezbeđuje da rečnik prati trenutni sadržaj i promene klipborda i automatski se aktivira i prevodi frazu kada se promena detektuje.

Dodaj stavku priručnog menija u IE

Kada je „čekirana“, ova stavka obezbeđuje da se stavka „Prevedi sa Di recnikom“ postavi u priručni meni Internet Explorer-a.

Kontekstno osetljiv prevod

Kada je „čekirana“, ova stavka obezbeđuje da se prelaskom miša preko prevoda, u prvi plan (u vidu Hint-a) naznači fraza koja se nalazi ispod kursora miša. U trenutku kada je neka fraza naznačena, ako pritisnete i zadržite levi taster miša – dobićete sva druga značenja naznačene fraze. Ako pritisnete desni taster miša – rečnik će u prvi plan staviti naznačenu frazu – kao da ste je ručno upisali.

Prikazuj dnevni savetnik

Kada je „čekirana“, ova stavka obezbeđuje da rečnik nakon svakog pokretanja prikzuje Dnevni savetnik sa „savetom“ za taj dan. Dnevni savetnik, kada se rečnik smesti u Tray, biće u vidu standardne „balonske“ poruke. Kada je rečnik već otvoren, Dnevni savetnik će biti u vidu sistemskog teksta.

Zaključaj editor

Kada je „čekirana“, ova stavka obezbeđuje da polje za prevod inicijalno bude „zaključano“ nakon prikaza prevoda.

Snimi poslednje fraze

Kada je „čekirana“, ova stavka obezbeđuje da pritiskom na taster ENTER snimimo prevedenu frazu u listu poslednjih korišćenih fraza. Fraza će biti snimljena u listu poslednjih fraza i kada je pozvana priručnim menijem In t ernet Explorer-a ili preko "brzog klipborda".

Prelomi prevod

Kada je „čekirana“, ova stavka obezbeđuje da se dugački prevodi (sa puno značenja) prelome u novi red, umesto da se prikažu u jednom redu. Time se značajno štedi radni prostor korisnika.

Zapamti poslednju poziciju rečnika

Kada je „čekirana“, ova stavka obezbeđuje da se rečnik pojavi na istom mestu gde ste ga posledji put (ostavili) zatvorili.

Izgovor

Kada je „čekirana“, ova stavka obezbeđuje da pritiskom na taster ENTER izgovori „selektovana“ engleska reč.

Senčenje prozora za prevod

Kada je „čekirana“ ova stavka, prozor za prevod će se pojavljivati osenčen. S obzirom na brzinu Vašeg računara možete izabrati da to senčenje bude brzo, srednje ili sporo. Neki stariji operativni sistemi ne podržavaju ovu tehniku, pa ona i neće biti za njih vidljiva.

Pozivanje rečnika tastaturom

Kada je „čekirana“, ova stavka obezbeđuje da pritiskom na određenu kombinaciju tastera pozovemo rečnik, čak i kada se nalazimo u nekom sasvim drugom programu.

Podešavanje kombinacije za pozivanje rečnika tastaturom

Kombinaciju tastera za pozivanje rečnika tastaturom možete podesiti izborom jedne od ponuđenih stavki: ALT+F9, ALT+F10, ALT+F11, ALT+F12.


Pomoć

Podmeni „Pomoć“ sadrži uglavnom standardne funkcionalnosti koju očekujete od svakog „Help“ menija. Iz ovog menija se može: pozvati standardna Help datoteka (u HTML formatu), podsetiti o raspoloživim prečicama sa tastature, poslati E-mail, usmeriti web browser na našu Web stranu, pogledati osnovni podaci o programu, i sl.

Detaljnije o stavci „Pomoć“ biće u nastavku dokumenta.

Podmeni „Pomoć“


Zatvaranje rečnika

U zavisnosti od toga da li je u podešavanjima izabrano da se rečnik zatvara u Tray, stavka priručnog menija za zatvaranje rečnika (na slici) može imati drugačiji naslov.

Prečica sa tastature ALT+F4 takođe zatvara rečnik.

Zatvaranje programa u „Tray“ ili izlazak iz programa


Prečice sa tastature

Upotreba miša u radu sa rečnikom se može svesti na minimum a umesto njega se može koristiti tastatura – što je naročito važno za iskusnije korisnike. Sledi spisak raspoloživih prečica sa tastature:

Jezik

ALT+L Promena jezika pretrage (Oba, Engleski, Srpski)

ALT+I Promena jezika interfejsa (Srpski, Engleski)

Kriterijumi za pretraživanje

ALT+B Upoređuje početak reči

ALT+C Upoređuje sadržaj reči

ALT+E Upoređuje kraj reči

ALT+W Upoređuje celu reč

Polje za unos fraze

ENTER Pamti frazu, vraća prevod (ako je zatvoren) ili izgovara frazu

ESCAPE Zatvara prevod, briše upis ili zatvara rečnik

ALT+U Pozivanje priručnog menija

ALT+Z Izgovara englesku frazu

ALT+S Otključava polje prevoda

ALT+H Briše poslednje korišćene fraze

Standardne

CTRL+A Selektuje sve u polju prevoda ako je otključano

CTRL+C Kopira selekciju iz polju prevoda ili polja za unos fraze

CTRL+V Kopira tekst sa klipborda u polje za unos fraze

CTRL+X Seče i kopira na klipbord selekciju iz polja za unos fraze

Kopiranje na klipbord

ALT+1 Kopira samo frazu

ALT+2 Kopira samo prevod

ALT+3 Kopira i frazu i prevod

Pozicija rečnika

ALT+GORE Poravnava rečnik uz gornju ivicu ekrana

ALT+DOLE Poravnava rečnik uz donju ivicu ekrana

ALT+LEVO Poravnava rečnik uz levu ivicu ekrana

ALT+DESNO Poravnava rečnik uz desnu ivicu ekrana

CTRL+ALT+GORE Fino pomeranje rečnika ka gornjoj ivici ekrana

CTRL+ALT+DOLE Fino pomeranje rečnika ka donjoj ivici ekrana

CTRL+ALT+LEVO Fino pomeranje rečnika ka levoj ivici ekrana

CTRL+ALT+DESNO Fino pomeranje rečnika ka desnoj ivici ekrana

Pomoć

F1 Dokument "Pomoć"

ALT+K Spisak najvažnijih prečica sa tastature

ALT+T Dnevni savetnik

ALT+D Dobrovoljne donacije

ALT+A O programu

Globalno pozivanje rečnika

ALT+[F9, F10, F11 ili F12] Otvara rečnik


Pomoć

Kao što je ranije već rečeno, stavka „Pomoć“ priručnog menija sadrži uglavnom standardne funkcionalnosti koju očekujete od svakog „Help“ menija.

Stavka „Pomoć“ priručnog menija


Dokument "Pomoć"

Izborom ove stavke pozivate standardnu Help datoteku (u HTML formatu). Isti efekat postižete i prečicom sa tastature F1.

Dokument "Pomoć"


Tastatura

Izborom ove stavke u obliku sistemskog teksta biće prikazane najvažnije prečice sa tastature. Isti efekat postižete i prečicom sa tastature ALT+K.

Sistemski tekst „Prečice sa tastature”


Dnevni savetnik

Izborom ove stavke u obliku sistemskog teksta biće prikazan „savet“ za taj dan. Isti efekat postižete i prečicom sa tastature ALT+T, koju možete pritiskati i više puta da biste listali redom i druge „savete“.

Sistemski tekst „Dnevni savetnik”


Dobrovoljne donacije

Izborom ove stavke u obliku sistemskog teksta biće prikazana poruka o dobrovoljnim donacijama. Isti efekat postižete i prečicom sa tastature ALT+D.

Sistemski tekst „Dobrovoljne donacije”


Posetite našu Web stranu

Izborom neke od ponuđenih stavki podmenija „Posetite našu Web stranu” Vaš web browser će biti automatski preusmeren na matičnu stranu naše firme, gde možete pročitati o novostima u firmi, pogledati stranicu posvećenu ovom rečniku ili stranicu koja se odnosi na Tehničku podršku naše firme.

Web podrška


Po šaljite E-mail

Izborom neke od ponuđenih stavki podmenija „Pošaljite E-mail” možete stupiti u kontakt sa nama putem E-mail-a i predložiti neko softversko unapređenje, prijaviti grešku u softveru, zatražiti bilo kakva dodatna objašnjenja od Tehničke podrške ili registrovati Vašu kopiju rečnika.

E-mail podrška

Rečnik će automatski popuniti odredišnu adresu i neke druge sistemske podake, a na Vama je da upišete tekst poruke.

Primer automatski generisanog E-mail-a


Registrovanje programa

Već je više puta do sad rečeno da je ovaj rečnik potpuno besplatan, i da za njegovo korišćenje nije neophodna nikakva novčana nadoknada niti registracija.

Međutim, procedura za registrovanje Vaše kopije rečnika (putem E-mail-a) ipak postoji kao opcija i usmerena je isključivo na organizovano održavanje programa. Pri tome uglavnom mislimo na slanje cirkularnih E-mail-ova o novim verzijama rečnika i slično.

Svi podaci koje nam pošaljete služiće isključivo radi podrške, i ni pod kojim okolnostima neće biti dostupni trećim licima na uvid.

Proceduru za registrovanje započinjete pozivanjem Vašeg E-mail klijenta iz samog rečnika:

Stavka „Podešavanja / Pomoć / Pošaljite E-mail / Registrovanje ...“

Zatim popunite nedostajuće podatke u formularu i pošaljite.

E-mail za registrovanje


O programu

Izborom ove stavke u obliku sistemskog teksta biće prikazani osnovni podaci o trenutnom izdanju rečnika. Isti efekat postižete i prečicom sa tastature ALT+A.

Sistemski tekst „O programu”